shell.jpg

¿Cuántas veces has intentado instalar una aplicación en tu sistema Linux y has olvidado el comando sudo? ¿O cuántas veces has escrito de forma equivocada un comando o un argumento del mismo?

thefuck es una aplicación que es capaz de corregir tu último comando. Se basa en una serie predefinida de errores, pero además te permite añadir tus propias reglas, en caso que quieras añadir algunas nuevas o modificar las ya existentes.

Veamos un pequeño ejemplo. Supongamos que ejecutamos:

➜ apt-get install vim
E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?

Hemos olvidado añadir sudo. En vez de repetir la operación, todo lo que tienes que hacer es ejecutar:

➜ fuck
sudo apt-get install vim [enter/↑/↓/ctrl+c]
[sudo] password for nvbn:
Reading package lists... Done
...

Y como ves, éste automáticamente añade sudo delante del comando que has ejecutado previamente.

También es capaz de corregir errores en cadena, es decir, puedes corregir el último comando, y si éste tiene otro error, thefuck es capaz de reaccionar al mismo y así sucesivamente.

Aquí tienes un pequeño gif animado con algunos ejemplos para que te hagas un mejor idea:

En su repositorio, además del código fuente, también tienes las instrucciones de instalación y uso.

Entradas relacionadas: